Error After Update Sp Simple Portfolio - Question | JoomShaper

Error After Update Sp Simple Portfolio

I

Igor

Extension 2 months ago

Hello!

After updating the component SP Simple Portfolio Administrator Component to version 2.0.7 I got an error while accessing the site: Parse error: syntax error, unexpected ':', expecting ';' or '{' in /path_to/components/com_spsimpleportfolio/router.php on line 88

I read that this is because of the PHP version. My current PHP version is 5.6, Joomla version is 3.10.11 When trying to remember the version of PHP on 7.4, the site breaks down with an error: Parse error: syntax error, unexpected '.', expecting '&' or variable (T_VARIABLE) How to fix these errors? Is it possible to return the previous version of SP Simple Portfolio?

0
20 Answers
I
Igor
Accepted Answer
2 months ago

Please give me an answer or any instructions or an old version of Sp Simple Portfolio to help solve my problem. My site is down...

0
I
Igor
Accepted Answer
2 months ago

I did not wait for the answer, I restored the site from a backup. I also created a site mirror to reproduce the error. What is the correct update sequence? What have I done wrong?

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 1 month ago

Hello Igor

Apology for the inconvenience. Please share your administrator access here to check the issue. Use the Hidden Content box to share the credentials. Make sure that you have a full site backup with you before sharing.

Best regards

0
I
Igor
Accepted Answer
1 month ago

Hello!

Please go to my mirror site (see hidden content) I already made a backup Now i have: Joomla 3.10.11 PHP 5.6 SP Page Builder Pro 3.6.2 (ready to update to 3.8.9) - update runs without error SP Simple Portfolio 1.9 (readey to update to 2.0.7) - when updating, an error occurs (see above) and the site becomes unavailable

0
I
Igor
Accepted Answer
1 month ago

What's going on with my mirror site now? I see that the site is down. What's going on with my mirror now? I see that the site is down. I see that you have updated the component SP Simple Portfolio to 2.0.7 Please tell me the status

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 1 month ago

So far, I have found it working on Kidzy quickstart on my localhost. But on your site, the portfolio does not work. I have update all the extensions to the latest version. But it still shows empty page. I will need some more time to catch the issue.

0
I
Igor
Accepted Answer
1 month ago

Hello! what is happening with my case? what status? When can we expect a solution to the problem?

0
I
Igor
Accepted Answer
4 weeks ago

Ofi Khan, where are you? Why aren't you answering me about the status of my case? It's been over a month since I opened this case This is very bad work!

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 4 weeks ago

Apology for the long delay. Please share your cPanel access here to check the issue.

0
I
Igor
Accepted Answer
4 weeks ago

cPanel - is it a hosting control panel? what exactly do you need access to?

0
I
Igor
Accepted Answer
4 weeks ago

Ofi? Please answer me, don't disappear.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 weeks ago

I have found something. I uninstalled SP Kindergarten and then the error was changed. Then the error is shown for SP Simple Portfolio. I think the issue is not related SP Kindergarten. I have checked that the site is running on PHP 5.6. Please check the issue on PHP 7.4.

0
I
Igor
Accepted Answer
3 weeks ago

Hello!

I changed PHP version to 7.4 Got a new error: 404

syntax error, unexpected 'Условия' (T_STRING), expecting ')'

You can chek it on my site UPDATE: I updated the old AcyMailing component The error went away, but there were other problems:

  1. Error notifications on the main page
Notice: Undefined property: stdClass::$content in /home/oc-club/temp.oc-club.ru/docs/templates/shaper_kidzy/sppagebuilder/addons/slideshow_full/site.php on line 121

Notice: Undefined property: stdClass::$button_one_text in /home/oc-club/temp.oc-club.ru/docs/templates/shaper_kidzy/sppagebuilder/addons/slideshow_full/site.php on line 125

Notice: Undefined property: stdClass::$url in /home/oc-club/temp.oc-club.ru/docs/templates/shaper_kidzy/sppagebuilder/addons/testimonialpro/site.php on line 32

Notice: Undefined property: stdClass::$url in /home/oc-club/temp.oc-club.ru/docs/templates/shaper_kidzy/sppagebuilder/addons/testimonialpro/site.php on line 32

Notice: Undefined property: stdClass::$position in /home/oc-club/temp.oc-club.ru/docs/templates/shaper_kidzy/sppagebuilder/addons/testimonialpro/site.php on line 45

Notice: Undefined property: stdClass::$url in /home/oc-club/temp.oc-club.ru/docs/templates/shaper_kidzy/sppagebuilder/addons/testimonialpro/site.php on line 32

Notice: Undefined property: stdClass::$position in /home/oc-club/temp.oc-club.ru/docs/templates/shaper_kidzy/sppagebuilder/addons/testimonialpro/site.php on line 45
  1. When I try to edit the main page in Frontend Editor, I don't see my page blocks. Only if you edit without visual viewing ..
  2. Background and following events (SP Kindergarden: events) are not displayed on the main page
0
I
Igor
Accepted Answer
2 weeks ago

Ofi Khan, hello! Please answer!

0
I
Igor
Accepted Answer
2 weeks ago

Ofi! Didn't receive answer from you...

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 1 week ago
  1. Solved.
  2. Homepage has some issues with frontend editing.
  3. I have added a test event menu item. It looks okay.
0
I
Igor
Accepted Answer
1 week ago

Hello, Ofi! Thanks for answering.

  1. Because this site is a mirror of main site, please detail your actions for resolve error
  2. what are the issues and how to fix them?
  3. the background did not appear on the slideshow. see my main site oc-club.ru
0
I
Igor
Accepted Answer
3 days ago

Hello! Ofi, answer, please

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 days ago
  1. Copy the files from the mirror site to your main site.
    templates/shaper_kidzy/sppagebuilder/addons/slideshow_full/site.php
    templates/shaper_kidzy/sppagebuilder/addons/testimonialpro/site.php
  2. Sorry, I am still unable to find the issue. It is conflicting with Kidzy template on your site.
  3. If the issue same on the mirror site, share some screenshots and links. I will check it.
0
I
Igor
Accepted Answer
2 days ago
  1. Error notices still exist:
  2. I will wait for your information
  3. Background on the mirror site: Background on the main site:
0