Changes Not Applying SPPB 5 / Joomla5 - Question | JoomShaper

Changes Not Applying SPPB 5 / Joomla5

S

sdlsites

SP Page Builder 5 months ago

I have included a video of my issue in the hidden content.

  • Joomla 5
  • Pagebuilder 5
  • CDN Disabled
  • Cache disabled
  • Private Browser

In addition to the publish/unpublish/naming/creation issue within the pagebuilder backend, we are having problems where media is deleted but still showing up in the media list or uploaded and now appearing within the folder.

This seems to be a browser cache issue with SPPB. I literally have to delete browser cache after each action. I have never seen this issue before with any other extension or prior version of SPPB.

how do i resolve this so that it functions as intended?

0
42 Answers
Mehtaz Afsana Borsha
Mehtaz Afsana Borsha
Accepted Answer
Support Agent 5 months ago #148646

Hi

Thanks for contacting us and glad to know that its now solved. Sometimes this kind of issues occured by cache. Please try to use the latest versions. You can now close this post by accepting the answer.

-Regards.

0
S
sdlsites
Accepted Answer
5 months ago #148665

this isnt solved.

0
Mehtaz Afsana Borsha
Mehtaz Afsana Borsha
Accepted Answer
Support Agent 5 months ago #148669

Could you please keep a full site backup and reinstall page builder? Then try again.

0
S
sdlsites
Accepted Answer
4 months ago #148725

Reinstall didn't make a difference. Tried a fresh install as well and it is still browser caching everything, despite the browser cache plugin being disabled and caching set to none. This issue is also browser agnostic. The only way to make it work is the go to developer tools > network > disable cache (chrome).

0
Mehtaz Afsana Borsha
Mehtaz Afsana Borsha
Accepted Answer
Support Agent 4 months ago #148832

Glad to know that you have found the solution and thanks for sharing.

0
S
sdlsites
Accepted Answer
4 months ago #148890

This is not a solution. It is more information for you to assist. I can not tell clients that they need to override their browser to make this work.

How do we actually fix it versus find a workaround?

0
Mehtaz Afsana Borsha
Mehtaz Afsana Borsha
Accepted Answer
Support Agent 4 months ago #148967

Hi

Sometimes we have this cache issue. That's why you have to clear that caches.

0
S
sdlsites
Accepted Answer
4 months ago #148999

This isn't occasional or a minor cache issue. This is a bug or a bad design. Unless browser cache is turned off from the start, the changes DO NOT EVER apply. It isn't just a matter of clearing cache after making the change. Half of the time we will unpublish a page or change a name, clear the browser cache, and the change never applies. We need to first disable browser cache on the browser, then make the change, then it shows up.

I can understand having to clear cache, but this is not simply clearing cache. It is an issue of updates never being applied.

0
Ralph-Uwe Scherer
Ralph-Uwe Scherer
Accepted Answer
1 week ago #161783

I can confirm that this is an issue in Joomla 5 PHP 8.1, 8.2 and 8.3.

0
Mehtaz Afsana Borsha
Mehtaz Afsana Borsha
Accepted Answer
Support Agent 4 months ago #149246

Could you please give me your super admin access? In the meanwhile I will add it also in our buglist.

0
S
sdlsites
Accepted Answer
4 months ago #149314

We have many websites that are experiencing this issue. Do you have an override that we can apply or do you need access to one of them see what I am talking about?

0
Mehtaz Afsana Borsha
Mehtaz Afsana Borsha
Accepted Answer
Support Agent 4 months ago #149322

Hi

Please share one of your site access so that we can check. And make sure you have a full site backup.

0
S
sdlsites
Accepted Answer
4 months ago #149414

Included in hidden content.

0
Mehtaz Afsana Borsha
Mehtaz Afsana Borsha
Accepted Answer
Support Agent 4 months ago #149516

Could you please check your site? I cant access on that.

0
S
sdlsites
Accepted Answer
4 months ago #149578

see notes. mistyped

0
S
sdlsites
Accepted Answer
4 months ago #150022

Is there any update on this?

0
Mehtaz Afsana Borsha
Mehtaz Afsana Borsha
Accepted Answer
Support Agent 4 months ago #150137

Could you please mention what you have done to prevent the caching issue to the server end? Maybe you configured caching-related settings to the server end, due to that, the server always triggers the default settings even after anyone changes and edits the pages.

0
S
sdlsites
Accepted Answer
4 months ago #150168

Browser cache, Site cache, CDN are all disabled and we are using a private browser.

This only started after we upgraded from Pagebuilder 4 to Pagebuilder 5.

0
Ralph-Uwe Scherer
Ralph-Uwe Scherer
Accepted Answer
1 week ago #161784

Having the exact same issue. I am hoping this gets resolved soon. I am probably going to go back to Joomla 4 and Pagebuilder 4 for now.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 4 months ago #150295

Hello sdlsites

Please take a full site backup with Akeeba Backup in ZIP format and share here. Follow this tutorial. I will check it on my localhost.

Best regards

0
S
sdlsites
Accepted Answer
4 months ago #151638

See link in hidden content to a test site where you should be able to replicate the issue that we are having.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago #151950

Please disable admintools system plugin and check your issue.

0
S
sdlsites
Accepted Answer
3 months ago #151985

Admin Tools has been disabled and I am still having the same issue when publishing / unpublishing pages.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago #152694

Please disable joomlatools system plugin and then check your issue.

0
S
sdlsites
Accepted Answer
3 months ago #152776

After logging in, I am unable to access SPPagebuilder. I tried to reinstall with no success.

https://prnt.sc/y3zPheZ4glet

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago #152822

Please share your administrator and cPanel access here to check the issue. Use the Hidden Content box to share the credentials. Make sure that you have a full site backup with you before sharing.

0
S
sdlsites
Accepted Answer
3 months ago #153021

I have gone ahead and created another testing environment for this so that you can do anything needed to find the issue. I have also disabled as many third-party extensions as possible, changed cloudflare to not cache, removed all proxy, and removed any site cache. I am still having a problem.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago #153089

Please check your site now. I have disabled joomlatools plugin.

0
S
sdlsites
Accepted Answer
3 months ago #153114

Same issue. See video in hidden content.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago #153161

I have disabled cache in browser console. Now it is working. Please talk to your hosting provider to disable any caching if enabled. Also, disabled all third-party caching. It will be fixed.

0
S
sdlsites
Accepted Answer
3 months ago #153216

Hello,

This is a known workaround and was in one of my first messages on this forum, but it isn't acceptable for us to ask our admins to adjust their browser settings to make this work. There is nothing that is is caching on the server and the only change was upgrading to SPPB5. We never had this issue before the upgrade.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago #153284

I have not asked to adjust your admin browser settings. The response I have got is from the development team. I have checked your site on my localhost. There are no issues. The issue is definitely on your server settings. The development team confirms that there are some caching mechanism which is blocking the resources. I would like to request you to check the site on different hosting or localhost. Hopefully, you will see the differences.

0
S
sdlsites
Accepted Answer
3 months ago #153336

Hello - If you are not asking our site administrators to adjust browser settings, which was the first thing I mentioned as part of our troubleshooting, how would they block browser caching?

Can you tell me what related to caching would be different in SPPB 5 versus SPPB 3? This only became an issue after updating and the only extension that is having a cache issue is SPPB 5. What specifically should I be looking for to resolve this?

0
LR
Laurent Robin
Accepted Answer
3 months ago #153295

i had the same issue and it's something with caching settings from your hosting company. i have no idea what it is but i found out that i had allways this issue on the same hosting company. But somehow it's also a SPBB issue because all other components and third parties plugins don't have any issue of caching. Anyways. To fix that problem i'm using the "Cache Killer" free extension for Google Chrome and turn it on for the development time of the site and all works fine. i suggest you to try it sdlsites. Several users of SPPB pro did report this issue in the forum. An official fix and the elimination of this problem by the Joomshaper development team would be greatly appreciated...

0
S
sdlsites
Accepted Answer
3 months ago #153337

Thanks. The issue that we are having is that we aren't always the ones making updates to the site content. We design, build, hosting and support, but often our clients perform updates and we can't provide them with workarounds for things that should work. I apprecaite the suggestion and I am going to look into it to see if it is an easier fix for going into the dev tools and disabling cache, but I really wish we could just get a clear answer for what we should be looking for.

0
E
Eric
Accepted Answer
2 months ago #155650

And cache killer isn't the solution. It doesn"t work properly. I have the same problem of cache with it active.

0
LR
Laurent Robin
Accepted Answer
3 months ago #153352

i agree. the most important would be to identify the problem so we know what the hosting company server does others and also i would allow the Joomshaper team to fix the problem. There are bunch of reports about this issue since the release of SPBB5. Something did change indeed as like for many users i'm using SPBB for years and it never had this problem before. The Joomshaper Team should really handle this problem as a priority. I totally agree with you, those workarounds are not a solution and even if the Builder is a great product, i will be the first to look for another and more stable product if it still not fixed.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 3 months ago #153565

Thanks for the discussion, friends. I have shared it with the team. The development team will work on the caching issues for the future versions.

Have a good day, all!

0
S
sdlsites
Accepted Answer
1 month ago #157665

Do we have any update on this? We are still having the same issues. opcache is disabled, cloudflare is DNS only, all cache is turned off.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 1 month ago #157799

Sorry, no updates from the team so far 😔

0
E
Eric
Accepted Answer
1 month ago #158760

Can we hope one day for a solution from your company regarding this cache problem ?

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 1 month ago #158785

Yes, we are trying our best to minimize the problem.

0