500 Behavior::modal Not Found With Editors Like JCE And Ark Editor - Question | JoomShaper

500 Behavior::modal Not Found With Editors Like JCE And Ark Editor

LC

Lito Cabezas

SP Page Builder 1 month ago

Hi,

Whenever I use an editors like JCE or Ark Editor as default and I use System Editor on editing, I always get "500 behavior::modal not found."

We tried to use TinyMCE and it works fine. What might be the cause of the error when using a different editor?

We are using latest J5 and PHP 8.1.27

Appreciate your advise.

0
4 Answers
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 1 month ago #149803

Hi Lito,

In general in SPPB 5.2.x we support only TinyMCE and partially JCE. We never supported Ark Editor.

Your problem may be caused that your Joomla loads both plugins from JCE and Ark. With only JCE 2.9.6x there shouldn't be any errors, I use that every single day.


  1. In Global Configuration switch Error Showing to Maximium and Turn on Debug Mode - then check Editor again.
  2. And to be sure there are no "weird" conflict, on test subdomain install raw Joomla 5.0.x + SPPB 5 + JCE 2.9.62 and test again. You see that it will work.
0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 1 month ago #149809

jce_system_editor_2024.gif

Joomla 5.0.3 + JCE Core 2.9.62 + SPPB 5.2.7 (no Ark installed!) TODAY'S Screenshot

0
LC
Lito Cabezas
Accepted Answer
1 month ago #149827

Thanks Paul,

Initially, we only have JCE installed but when I noticed that TinyMCE works, I uninstall JCE and tried Ark Editor. We only have one running now. Anyways, will uninstall Ark and install again JCE and see.

We are using both SPB and JCE on some of our sites and it's working alright.

Regards.

0
LC
Lito Cabezas
Accepted Answer
1 month ago #149842

We already reinstall JCE but same error.

This is a screenshot of the error. Not sure if it will help.

Regards.

0