Offcanvas Menu Display All Menu Levels - Question | JoomShaper

Offcanvas Menu Display All Menu Levels

B

Bendict

Helix Framework 1 month ago

How do I display a menu with all level open in offcanvas menu?

Displayed on attached img doens't work ![https://produktion01.say-it.dk/images/Skaermbillede%202024-05-27%20kl.%2010.27.37.png]

0
17 Answers
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 1 month ago #157937

Hello Bendict

Please follow this documentation. Hopefully, it will solve your problem.

Best regards

0
B
Bendict
Accepted Answer
1 month ago #157944

doesn't work :-(

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 1 month ago #157946

If I may....

This tip was created for raw Helix Ultimate for Mobile Menu only, but you used different method in desktop view. In that case you need ALSO that lines:

#modal-menu   .sp-megamenu-parent .sp-dropdown {
  position: initial; display: block; }

In Mobile view you have - all menu items are visible, so my orginal CSS from Guide helped ;)

Screenshot 2024-05-27 at 11-25-02 Loftisolering.png

0
B
Bendict
Accepted Answer
1 month ago #158252

Thanks, almost there Now it's visible but with the drop down function still attached to it - I need to get rid of that

0
B
Bendict
Accepted Answer
1 month ago #157947

Thanks, almost there Now it's visible but with the drop down function still attached to it - I need to get rid of that

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 1 month ago #158329

add also those lines:

#modal-menu ul.sp-megamenu-parent li.sp-has-child > a::after, 
#modal-menu ul.sp-megamenu-parent li.sp-has-child > span::after 
{content: ""; display: none; }
0
B
Bendict
Accepted Answer
1 month ago #158473

Hi, I've add the suggested lines but it doesn't change the menu?

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 1 month ago #158535

My CSS code removed drop down "arrows" in Dekstop view - or you wanted to remove something else? If yes, share screenshot and show me what!

0
B
Bendict
Accepted Answer
1 month ago #158950

OK here's a screendump off the menu and of what I need to achieve. So instead of a submenu that is styled with animation and boxed bg. I just need it to be really simple and have all menu items open at all time.

![https://produktion01.say-it.dk/images/DI-MENU-ISSUE.jpg]

You can see the production website and access the menu in question here: [https://produktion01.say-it.dk/]

Thank you very much for you help :-)

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 1 month ago #159037

Use also those lines:

.sp-megamenu-parent {margin: 10px 0px;}
#modal-menu ul.sp-megamenu-parent .sp-dropdown {transition: none;}
#modal-menu ul.sp-megamenu-parent .sp-dropdown .sp-dropdown-inner {
  background-color: transparent; padding: 5px;}
ul.sp-dropdown-items li.sp-menu-item > a::before {content: "- "; }
0
B
Bendict
Accepted Answer
1 month ago #159104

Cool thanks now I just need the submenu not animating on hoover (it jumps when activating)

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 1 month ago #159138

Check if you can disable Menu animation in Template Options > Menu > MegaMenu > Dropdown Animation

0
B
Bendict
Accepted Answer
1 month ago #159179

I've done that - but it has no effect

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 1 month ago #159222

Try also that line

#sp-header.header-with-modal-menu.center-layout .sp-megamenu-wrapper .sp-megamenu-parent>li.sp-has-child>.sp-dropdown {animation:none; animation-duration: 0s;}

0
B
Bendict
Accepted Answer
1 month ago #159333

Nope still animating - very strange

0
Paul Frankowski
Paul Frankowski
Accepted Answer
Senior Staff 1 month ago #159339

@Ofi - do you have any extra ideas? I don't :/

0
B
Bendict
Accepted Answer
1 month ago #159610

Hi, did you find a solution?

0