Articles Addon Issue After Upgrade From SPPB3 To SPPB5 - Question | JoomShaper

Articles Addon Issue After Upgrade From SPPB3 To SPPB5

Andrea Maestrini

Andrea Maestrini

SP Page Builder 1 month ago

Hi, one of many issues occuring after updating SPPB Pro is that the content of Articles Addons is no longer alligned with the others addons ant the image results cropped. As you can see in SPPB 3 everything looks smooth, after the upgrade and the "check content" procedure, the result is not what it was expected to be. Columns are properly bottom aligned and all margin and padding are 0px (as in SPPB3). How can I solve this? I'm working on the latest version of Joomla 4.x Thank you Andrea

SPPB 3 SPPB 5

0
5 Answers
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 1 month ago #159517

Good finding. I have talked with the development team. They have already fixed in the upcoming version by setting the height to auto. This version will release this week. Update and it will be fixed. No need to use Custom CSS for it.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 1 month ago #159485

Hello Andrea Maestrini

Apology for the inconvenience. Is it possible to share the page Export JSON from both SP Page Builder 3 and 5 for you? If possible, then share it. I will check the differences and fix it.

Best regards

0
Andrea Maestrini
Andrea Maestrini
Accepted Answer
1 month ago #159491

Yep, here you are. Thanks Andrea

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 1 month ago #159506

Please change the Thumbnail to Full Image and check the issue.

prnt.sc/0pg5hTB70Fp_

0
Andrea Maestrini
Andrea Maestrini
Accepted Answer
1 month ago #159512

Hi, I already did but didn't solve anything. Any other clue?

In SPPB3 the picture in Articles Addon was: .sppb-carousel-inner>.sppb-item>a>img, .sppb-carousel-inner>.sppb-item>img, .sppb-img-responsive { display: block; max-width: 100%; height: auto; }

In SPPB5 it's: .sppb-addon-articles .sppb-addon-article-layout-content img { width: 100%; height: 250px; object-fit: cover; }

Where does "height: 250px" come from???? I changed custom css to "height: auto" and now it works. I hope it won't affect other things in the site.

But the columns bottom align still is not working properly. I could try to fix it with custom css, but it shoult not being an issue! Updating fron SPPB3 to SPPB5 is always a millions troubles s shot! I'm waiting for an answer, thank you!

0