Open Graph Image For Facebook - Question | JoomShaper

Open Graph Image For Facebook

D

Donna

General 2 weeks ago

I need help. I have read the documentation several times.

I use the latest Joomlas 3.10.x, SP Page Builder Pro, Helix Ultimate framework.

I have Open Graph enabled for a default image. I have made the artwork according to the sizes required by Facebook.

My articles (and there are a lot) are always new, short lived and the information is posted on a public Facebook page. The image is simply our logo, yet it never shows up.

The Faceook debugger tells us the url has never been shared before and I get the code 200 but the image cannot be processed. The size of the image is below the 5mb limit. The result I get for our home page is:

Invalid Image Content Type Provided og:image URL, https://pgrny.org/images/og/op-pgrny-1200x630fb.jpg could not be processed as an image because it has an invalid content type.

The result from the individual page is:

This URL hasn't been shared on Facebook before. (you have the option here on the FB debugger to fetch new information and it never does)

The individual articles are created via Joomla on the front end and are individual pages of the website.

Should I write open graph properties on the Helix Ultimate template? I have the Faceboook Blog option enabled.

This is very confusing and it has never worked correctly since going to SP Pagebuilder and Helix.

Global Configuration for SP PB is enabled. SP PG page settings is enabled. Helix Ultimate Template options is enabled.

Can someone please help.

We have our website limited to viewing only in the US and Canada.
Here is one link to show what the pages that do not show an image on Facebook: https://pgrny.org/index.php/more/pgrny-current-missions/r4-5-honor-mission-vernon-e-estes-us-army-veteran-fri-11-19-2021-ballston-spa-schenectady-ny?fbclid=IwAR1pXSRSD4LWR8J2J9EvEwP7Y2UyXelNdrKgOMciCtI8rMSA1AUcxuNsOXo

All I am trying to do is get the open graph to show our logo. Any help would be greatly appreciated. Donna

PS Our main domain is https://pgrny.org

0
23 Answers
D
Donna
Accepted Answer
1 week ago

Good point, I will do that.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 2 weeks ago

Hi there,

Thanks for contacting us. Sorry for the inconvenience. Will you please provide me the Joomla administrator access to check the issue? I will check & get back to you soon. 

-Thanks

0
D
Donna
Accepted Answer
2 weeks ago

Thank you Toufiq! Make creds are sent.

Donna

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 2 weeks ago

Can't visit your site.

0
D
Donna
Accepted Answer
2 weeks ago

What country are you trying to visit it from?

Thank you Donna

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 2 weeks ago

Bangladesh

0
D
Donna
Accepted Answer
2 weeks ago

Toufiq,

You should be able to get on our website now.

Thank you much, Donna

0
D
Donna
Accepted Answer
2 weeks ago

Toufiq,

Were you able to log in to our site? Can you offer any assistance?

Thank you in advance, Donna

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 2 weeks ago
0
D
Donna
Accepted Answer
2 weeks ago

This still does not work. The space is there where I logo image should go, but it does not render the our logo image at all.

Here is the FB debugger information for our main site home page:

Invalid Image Content Type Provided og:image URL, https://pgrny.org/images/og/fb_og_logo630x315.jpg could not be processed as an image because it has an invalid content type.

Yet it is a standard jpg. I have tried jpeg and pgn. Nothing works. And our server does process gzip images.

Any ideas??

Thank you Donna

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago
0
D
Donna
Accepted Answer
1 week ago

All I saw this morning is a listing for a funeral mission where a giant featured image was loaded. That's not our logo. So are you telling me in order to get our logo on each posting to facebook we have to use the featured image per article???

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

Yes, you have to use the feature image to display open graph image. Thanks

0
D
Donna
Accepted Answer
1 week ago

So there is no way to show our logo on everything as a default?

I physically have to add it to every article???

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

So there is no way to show our logo on everything as a default?

You have to add manulally

0
D
Donna
Accepted Answer
1 week ago

If we leave all the blog stuff blank and remove FB id, will it pull our logo.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

Then you have to use third-party extension. Thanks

0
D
Donna
Accepted Answer
1 week ago

Thank you, I will give that a try.

Not what I expected from using the blog at all, and then having to have a feature image.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

That you are looking exactly this feature doesn't exist. Thanks

0
D
Donna
Accepted Answer
1 week ago

Toufiq, Thank you for your time. It's a shame that Joomla or someone can't come up with a default graphic for either articles or categories. I too many that work on certain areas of the site and they are sometimes forgetful in what all they must do. A default would be ideal.

Best, Donna

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

Even Joomla core doesn't have this feature. :(

0
D
Donna
Accepted Answer
1 week ago

Toufiq,

I know, there are unhappy people on the forums there as well that this option doesn't exist.

Seems like between the social media giants and Joomla and WP someone would come up with a way to do this.

Thank you, Donna

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

You can add a feature request on Joomla github. Thanks

0