Blocks & Layouts Not Working - Question | JoomShaper

Blocks & Layouts Not Working

RA

Rafael Alvarez

SP Page Builder 1 week ago

Hi

Blocks & Layouts are not working, we did install SP Page Builder Pro yesterday on a clean Joomla installation.

Joomla version is 4.0.4 DB is MariaDB 10x PHP version 8.x SP Pro 3.8.0

They look as loading forever.

We did cleared site cache as browser caché as in another ticket explains and no luck.

Joomla is installed on a docker instance but I do think this has nothing to be with.

0
17 Answers
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 1 week ago

Apology if I have misunderstand anything. Unfortunately, we do not skype support. Let us try a fix. Please downgrade your PHP version to 7.4 and check the issue.

0
Mehtaz Afsana Borsha
Mehtaz Afsana Borsha
Accepted Answer
Support Agent 1 week ago

Hi

You have to active it.Input your email and license key to SP Page Builder -> Pages -> Option (on the right) -> License & Update (input your email and license key) -> Save and Close.Your License Key is located in your Dashboard.

​Then Clear Joomla and Browser cache.

Now check and let me know please

-Regards

0
RA
Rafael Alvarez
Accepted Answer
1 week ago

Hi Mehtaz

We did exactly this already .... twice. As I explained we saw this same issue on another post and we did followed the steps to solve it but no luck.

We did also a clean installation on a different server. No success on any.

Any other suggestion ?

0
Mehtaz Afsana Borsha
Mehtaz Afsana Borsha
Accepted Answer
Support Agent 1 week ago

Hi

Could you please mention the template name?

0
RA
Rafael Alvarez
Accepted Answer
1 week ago

Hi Mehtaz

We tried in 2 ways

Helix Template with example data (quickstart installation on site01) Casiopea and no template just Pagebuilder Pro on site02

Maybe is faster if we can chat or I can show you.

0
Mehtaz Afsana Borsha
Mehtaz Afsana Borsha
Accepted Answer
Support Agent 1 week ago

Please give me your super admin access on the hidden content so that I can check

0
RA
Rafael Alvarez
Accepted Answer
1 week ago

Ok, created

0
Mehtaz Afsana Borsha
Mehtaz Afsana Borsha
Accepted Answer
Support Agent 1 week ago

Hi,

Please follow this documentation below:

https://www.joomshaper.com/documentation/sp-page-builder/sp-page-builder-3

Read: SP Page Builder Documentation > Getting Started > If you cannot load Page templates Or Sections Library

https://prnt.sc/20rpcxn

Thank you

0
RA
Rafael Alvarez
Accepted Answer
1 week ago

Hi

You cannot be serious with this anwer. You mean we have to support ourselves after clean installation and creating you a super user account ?

What kind of support we will receive ? I mean we are technicians but not specialist in some areas, I hoped you could check what was wrong with our installation.

PS: we did already read this information and does not find what is wrong at our server. Before "bothering" we like to try solving ourselves.

0
Mehtaz Afsana Borsha
Mehtaz Afsana Borsha
Accepted Answer
Support Agent 1 week ago

Allow us some time please. I need to check. I will check and get back to you soon

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 1 week ago

Hello Rafael Alvarez

Thanks for the access. I have installed Akeeba Backup on your site and took a backupt for testing. I have checked your site on my localhost and SP Page Builder Layout Blocks are working good here. I think your server has some issues that can be solved at your hosting. You should contact your hosting provider. Please follow this documentation

Best regards

0
RA
Rafael Alvarez
Accepted Answer
1 week ago

Hi Ofi

Thanks for your answer, is the same as Menhtaz.

I think would be nice if we can chat. As explained before we do host our own, do not have any hosting provider. Looks you did not read our previous messages or maybe I did explained wrong.

We are working with Joomla since version 1.5, and although we are not programmers, we do have some linux skills.

Our server is installed on a Docker Container ( also explained before ) we are using lastest joomla image for that. This container does have PHP 8.0.x. This should not make any difference

For ex your LMS needs the calendar function and is needed to add this to the docker container. We posted one solution there if helps you for docker installations, so our LMS docker is working Ok whith the example data, but have the same issue with the Composer Pro

We read already your documentation, is the same as your collegue anwered us, this is not hellpful cause you do not say there is how to check we what you need to make it work.

What kind of technical support are we espected to have ? We did purchased thinking it was going to work, and realized we do have some prolbems we cannot solve without your help (not only with SP Page builder). Looks very easy but is not cause this.

0
RA
Rafael Alvarez
Accepted Answer
1 week ago

Hi Ofi

Nothing to apology. We just want to have it solved and we are ready to help if you need, so this is cause we did offer you to contact us by skype, or anydesk or teamviewer. It hink this benefits we both (solving it).

I think is much more easy if you can spend half an hour to install docker on your linux computer/server and get a try, I can give you some examples on how to do it if you need but is quite easy. The benefits of using this is that you do not need to install the whole OS each time and you can test with different versions Joomla images with different versions of PHP.

At your documentation you said you do support PHP 8.0.x, anywhere we will try with PHP 7 but we do prefer using the latest docker image that comes with PHP 8.0.x We did check already other components.

0
RA
Rafael Alvarez
Accepted Answer
1 week ago

Hi Ofi,

Yes it does work with PHP 7.xx we deployed another docker container with Joomla+PHP-7.4 and works Ok

So you should review if PHP8 is fully compatible cause it looks is not.

Kind Regards

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 1 week ago

Yes, you are right. We need to recheck it. I will share this finding with the developers for a review. Thanks for your co-operation.

0
RA
Rafael Alvarez
Accepted Answer
1 week ago

Hi Ofi,

Thanks to you. If you need us to test with PHP8 just let us know. Is very easy and fast for us to deploy a container with this.

Kind Regards

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 1 week ago

You are welcome. We might not need help right now technically. But defenitiley your feedback is much needed to improve our product.

0