Cannot edit Home Page after SP Page Builder Pro 4.0.3 upgrade - Forum | JoomShaper
Solved SP Page Builder

Cannot edit Home Page after SP Page Builder Pro 4.0.3 upgrade

Asked by Geordie van der Nest 4 years ago Last activity 7 months ago

I receive the following error when I want to edit my home page after updating to SP Page Builder Pro 4.0.3 and Helix Ultimate 2.0.11.

Fortunately the front end page still displays, but I cannot edit the page. It results in:
1064
You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '8) ORDER BY lft ASC' at line 3.

Accepted answer

Marked as the solution
Toufiq Senior Staff

Hi there,

Thanks for contacting us. Sorry for the inconvenience. Download this file & replace on this file location.

/components/com_sppagebuilder/helpers/articles.php

articles.php.zip

-Thanks

7 more replies

Samuel Desloges

For me this solution seems OK!

Samuel Desloges

Hi Toufiq,

I have update to SP Pagebuilder 4.0.4 and the update restore the error!
You must include the file in the update!!!!

Toufiq Senior Staff

We will do it soon. Thanks for your information.

‏‏‎ ‎J‏‏‎‎e‏‎‏‏‎‎n‏‏‎‎s W.‏‏‎

@Toufiq

Ronny Ko who has the same problem and also reported the problem a month ago, had not received any help at all on this problem until a week ago when I addressed it.
He reported today to me, the Problem is still present in version 4.0.5.

It is unfortunately still necessary to overwrite the article.php or correct it yourself.

components/com_sppagebuilder/helpers/article.php
line 53:
change !empty to !is_array

So I would like to ask you that you also forward the fix to the developers that the problem will be fixed in version 4.0.6.

Toufiq Senior Staff

I just informed again to our developer team. I hope they will check and let you know. Thanks

charlottesweb

Today I hade upgraded the SP Page Builder PRO to 6.2.3. And this problem has come. :(

Toufiq Senior Staff

Hi there,

Thanks for contacting us. Sorry for the inconvenience. Download this file & replace on this file location.

/components/com_sppagebuilder/helpers/articles.php

articles.php.zip

-Thanks

Log in to reply.