[Locked] Error after update on SP Pagebuilder 5.1.0 - Forum | JoomShaper
Solved SP Page Builder Locked

Error after update on SP Pagebuilder 5.1.0

Asked by Udo Graf 3 years ago Last activity 3 years ago

Hi, after update on newest version 5.1.0 table element produced error.

I could fix this in the PHP-File "addon-parser.php" on line 1112 as i add $storeData at the end:

$newContent .= self::getAddonHtmlView($contentAddon, $layouts, $pageName, $storeData);

and on line 1124 the same:

$repeatableItems = self::processRepeatableItems($repeatableItems, $addon_name, $layouts, $pageName, $storeData);

Example-Site that fix is ok: https://dev.myc-bingen.de/der-club/beitragsordnung

Please fix this as soon possible!

Thx pc-graf

Accepted answer

Marked as the solution
Paul Frankowski Senior Staff
3 years ago · edited

Hi All,

sorry for that, I don't how it could happen, during our tests was OK.

Qucik Fix:

Download, unzip and replace that file
info_1581_2023.png

File: addon-parser_UNZIP.zip


Offical update soon, probably we'll replace file on server on Monday.

3 more replies

Brad Thompson

Thanks for finding and solving this!

🍺

Comunicante

HI. I have the same issue ;(

Brad Thompson

Just follow the instructions that were posted.

Open the file "addon-parser.php" on line 1112 and add $storeData at the end so both lines look like this.

$newContent .= self::getAddonHtmlView($contentAddon, $layouts, $pageName, $storeData);

and on line 1124 the same:

$repeatableItems = self::processRepeatableItems($repeatableItems, $addon_name, $layouts, $pageName, $storeData);

Comunicante

Thanks Udo and Brad, I solved

dak

Many thanks, that solved the problem.

This question is locked, so it takes no new replies. Have a similar problem? Ask a new question.