Cannot open frontend page from page builder - Forum | JoomShaper
Solved SP Page Builder

Cannot open frontend page from page builder

Asked by Dina Abramson 5 years ago Last activity 4 years ago

At https://robdale-svcs.ca

I only get a "This page isn’t working" error and cannot edit pages.

I have cleard the cache and all is up to date.

Accepted answer

Marked as the solution
Toufiq Senior Staff

Thanks. Please close the fourm post. Thanks

25 more replies

Ariba Staff

Screen Shot 2021-04-28 at 8.32.29 PM.png
Hello
Can you kindly check this out and see if the solution works.
Also, kindly provide me a screenshot of the problem, it will be helpful.

Dina Abramson Asked this

Nothing has changed with the host since the site was completed a few weeks ago.

I notice that if I log into the front end first, the page opens when I click Frontend Editor. If I dont log into the front end first, it doesnt ask me to log in. I get the error

This page isn’t working
robdale-svcs.ca redirected you too many times.
Try clearing your cookies.
ERR_TOO_MANY_REDIRECTS

Dina Abramson Asked this

any other ideas as to why this isn't working?

Ariba Staff

Can you try following the instructions below?

1 . Enable the Error Reporting https://prnt.sc/wbqvjk
2. Disable the SEF https://prnt.sc/wbqvuw
3. Disable the JCE editor https://prnt.sc/wbqwai
4. Then try to check the front end editing.

Note: Before applying this process, please keep a backup of your site.

Also, which version of PHP are you using?

Dina Abramson Asked this

1 . Enable the Error Reporting - Done
2. Disable the SEF - Done
3. Disable the JCE editor - Done
4. Then try to check the front end editing. - Done - Same result

PHP = 7.4 - which is what it was when I developed the site.

Only 1 error reporting message
Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home/seladbor/public_html/plugins/system/helixultimate/core/classes/Minifier.php on line 226

I added FTP UN & PW if you want to take a look

Thanks

Ariba Staff

I am sorry, kindly bear with me. Can you check one more time if all these steps are ensured or not? If it still does not work, i will check from my end.

  1. Update template framework to the last version. If you have Helix II, please download the last version of raw Helix II template and install, it will update framework. In case of template based on Helix3, please download Helix3 template and install. This step is very important to update framework used by the template.
  2. Update JCE Editor to last available version
  3. After installation clear browser cache.
  4. Update SP Page Builder Pro to last available version.
  5. Clear Joomla cached files (System > Clear Cache > Clear All).
  6. Enable GZip compression in Joomla! Global Configuration.
  7. We suggest to use with PHP 7.0 or 7.1 at least. If you have problems with PHP 7.2, please use lower version.
  8. Disable all additional plugins which uses JQuery on front-end, for example, for Cookies plugins.
  9. Login on front-end as administrator and check again.
  10. Check also from different template set as default to find source of problems.
  11. Disable protection from Firewall component (Akeeba Tools Pro).

You can also try an easy fix: In Admin Tools navigate to Configure WAF, in the Cloaking section disable (set to NO) the one titled "Block tmpl=foo system template switch

Dina Abramson Asked this

I have folowed all steps but there is no change.

I uninstalled JCE and AdminTools

GZip was enabled already

Running PHP 7.4. Same results on 7.1 and 7.2.

7.3 breaks the site

Login on front-end as administrator - I can do this anyway. It's when I click on Frontend Editor in the backend that I get the error

Dina Abramson Asked this

I do see the following in the cPanel error log. This has been going on for several weeks

Dina Abramson Asked this

any further thoughts before I scrap the site and start over?

Toufiq Senior Staff

Sorry for inconvenience. Please check now and let us know.

I have turn off css & js compression from template manager and now it works. This is the initial solution. We will fix it next update of Helix.

-Thanks

Log in to reply.