Error: Cannot instantiate abstract class Joomla\Module\Popular\Administrator\Helper\PopularHelper - Forum | JoomShaper
Staff replied Templates

Error: Cannot instantiate abstract class Joomla\Module\Popular\Administrator\Helper\PopularHelper

Asked by Lisa Brandner 10 months ago Last activity 8 months ago

There is suddenly the following error message in the backend of my joomla 5.4.1 website :
Cannot instantiate abstract class Joomla\Module\Popular\Administrator\Helper\PopularHelper

I created the website one year ago as joomla 5 cms and I use template velvet 1.0.0 togehter with SP Page Builder since that time.
SP Page Builder has version 5.7.2 now,
template velvet still is in version 1.0.0.

Why do I get this error message now on the cms dashbord ?

7 replies

Paul Frankowski Senior Staff
10 months ago · edited

Hi Lisa,

as I saw that problem is caused by extra plugin that was installed one day and is enabled, not the core one. And that plugin is not J5 ready that's why display error and broke admin area!

Lisa Brandner Asked this

see below

Lisa Brandner Asked this
10 months ago · edited

But this site always has been a Joomla5 site aund this error is quite new.
Isn't it caused by helix frameware or the template itself?
Admin area is not really broken. You can use the menues...

Paul Frankowski Senior Staff
10 months ago · edited

In site footer was/is that name, that's why I asked. Really, check yourself.

Paul Frankowski Senior Staff
10 months ago · edited

I doubt. If you have new versions of our products. Besides more people on forum would ask for help, right.

Luis Costa

I have instaled from zero, update to 5.4.2 and after a few days without instaling nothing I get this message: Cannot instantiate abstract class Joomla\Module\Popular\Administrator\Helper\PopularHelper

Paul Frankowski Senior Staff
9 months ago · edited

Make research/Add topic on: forum.joomla.org

If you don't have any old plugin enabled.

Luis Costa

Solved.
I upgrade to Joomla 6.0.2 and its working ok.

Paul Frankowski Senior Staff

so it could be Joomla core issue.

Log in to reply.