SP Page Builder shoes an error message after installing under Joomla Ver 6.0.4 - Forum | JoomShaper
Staff replied SP Page Builder

SP Page Builder shoes an error message after installing under Joomla Ver 6.0.4

Asked by Immo 5 months ago Last activity 5 months ago

Hello, I have a problem with SP PageBuilder PRO after update to Joomla 6. I got this error message after installing SP PageBuilder Pro:

JInstaller: :Install: SQL-Fehler Can't create table web417_dfa2024_db.dfa24_sppagebuilder_versions (errno: 150 "Foreign key constraint is incorrectly formed")

What means: errno: 150 "Foreign key constraint is incorrectly formed

The Joomla-update from 5 to 6 was a success.
My version is 6.0.4 right now

Could something be incompatible with the PageBuilder?

https://www.dfa-tec.de/

3 replies

Paul Frankowski Senior Staff
5 months ago · edited

Hi,

Hard to say, can you using PHPMyAdmin create "missing" table dfa24_sppagebuilder_versions and try to install component again.


Option No2, install older version first, for example, SPPB 6.3.0 . If you, somehow, don't keep older versions - please take it from (link below) - click "Older versions" > Choose name.

Immo Asked this

Wonderful, it worked!

I created an empty table:

CREATE TABLE dfa24_sppagebuilder_versions (
id INT
);

Afterwards, there were no more problems installing PageBuilder - everything turned green ;-)

Thanks for the help/tip.

Paul Frankowski Senior Staff
5 months ago · edited

Great news! Congratulation.


Please mark topic as solved (link under "Reply")

Log in to reply.