EasyStore Database 1.8.1 issues - Forum | JoomShaper
Solved EasyStore

EasyStore Database 1.8.1 issues

Asked by Douglas B 5 months ago Last activity 4 months ago

Hello, I just updated EasyStore to 1.8.1 and have the following database issues:

Table 'jrx7o_easystore_orders' does not have column 'custom_invoice_id'. (From file 1.7.0.sql.)
Table 'jrx7o_easystore_orders' does not have index 'idx_custom_invoice_id'. (From file 1.7.0.sql.)
19 database changes were checked.
58 database changes did not alter table structure and were skipped.

Maintenance:Database > Select EasyStore > Update Structure > does not fix this issue.

Any advice would be appreciated, thank you.

Accepted answer

Marked as the solution
Ziaul Kabir Staff

To fix this issues, Please, go to your phpmyadmin data base -> SQL -> then paste this command and click go.

ALTER TABLE `jrx7o_easystore_orders`
ADD COLUMN `custom_invoice_id` VARCHAR(255) NULL AFTER `order_token`;

ALTER TABLE `jrx7o_easystore_orders`
ADD INDEX `idx_custom_invoice_id` (`custom_invoice_id`);

Thanks

4 more replies

Ziaul Kabir Staff

Hello,

Thanks for reaching out to us. Could you please share temporary administrator access to your Joomla backend? You can provide the credentials securely in the hidden content section. Also, please take a full backup of your site before we make any changes.

Once I have access, I’ll investigate further and see what’s causing the issue. Let me know once you’ve shared the details!

Best regards,

Douglas B Asked this

Please check hidden content.

Douglas B Asked this

thank you. i was able to work that out.
Had an error with the above sql command as the column order_token did not exist, so the AFTER order_token part generated an error.
Anyway, got it sorted. thank you for the help.

Ziaul Kabir Staff

It’s great to hear that your issue has been resolved.

If everything is working fine now, please mark the question as complete by accepting any of our answers.

Thank you!

Log in to reply.