SP Pagebuilder Pro 6.7.1 On Joomla 5.4.7 - Cannot Read Properties Of Undefined (reading 'data') - Forum | JoomShaper
Staff replied SP Page Builder

SP Pagebuilder Pro 6.7.1 On Joomla 5.4.7 - Cannot Read Properties Of Undefined (reading 'data')

Asked by gulfw 2 months ago Last activity 1 month ago

I'm getting the above error and cannot access SP Pagebuilder. Everything was fine a couple of weeks ago and I have made no major changes to configuration. I have followed the advice in other threads: downloaded latest version, cleared browser and Joomla caches, checked licence key etc. The 'Cannot Read Properties Of Undefined (reading 'data')' error appears in Chrome, I have opened the backend in Firefox and get 'can't access property "data", e.response is undefined'.

Thanks

8 replies

Atick Eashrak Shuvo Staff

Apologies for the inconvenience.

Could you please recheck the Site Administrator URL you provided? It appears to be redirecting me to the homepage, so I'm unable to access the administrator login page.

gulfw Asked this

Hi,
Thanks for the fast response - I can see an IP address has been blocked from access to the backend. I've now allowed that (see hidden details), so should be okay,

Atick Eashrak Shuvo Staff

Can I take a full backup of your site?

gulfw Asked this

Yes of course

Atick Eashrak Shuvo Staff

Your website appears to have blocked my IP address again. Could you please check and resolve the issue?

Atick Eashrak Shuvo Staff

I apologize for the inconvenience caused. Could you please check now and let me know if the issue is resolved on your end?

Looking forward to your response.

Best regards

gulfw Asked this

Hi Atick,

Yes, you seem to have resolved the issue. Thanks for a great job,

Atick Eashrak Shuvo Staff

Hi,

Thank you for confirming. I’m glad to hear that the issue has been resolved successfully.

We truly appreciate your kind words and are happy we could help. If you have any other questions or run into any further issues, please don’t hesitate to reach out.

Best regards

Confidant

Update: I cleared the site cache and it seems to work now. I'm using Joomla 6. Also I am using a secret URL parameter in AdminTools but I think that was unrelated. AI told me to check it.

Log in to reply.