cannot setup new license key - Forum | JoomShaper
Staff replied SP Page Builder

cannot setup new license key

Asked by László Bérczi 1 month ago Last activity 1 month ago

I cannot setup new license key, on my web site, under SP Page Builder Pro setttings, update license key gives 502 http errorduring saving the new license key.
Versions:
Joomla 4.4.14
SP Page Builder Pro 6.8

1 reply

Paul Frankowski Senior Staff
1 month ago · edited

Hi László,

there are 4 possible reasons:

  1. PHP settings, please increase your PHP limits: https://www.joomshaper.com/documentation/sp-page-builder/technical-requirements
  2. Or, a third-party plugin running on the onAfterStorage or onContentBeforeSave events throws a fatal PHP error when you hit Save.
  3. Or, Saving certain configuration strings or path settings triggers a security rule on server-level firewalls (like ModSecurity or Cloudflare). Can you disable ModSecurity for 3min in cPanel, recheck saving ?
  4. Or, maybe becuase SPPB Pro 6.8 was mostly developed for Joomla 5 and Joomla 6 engine.

Start from (1).

Log in to reply.