I cannot setup new license key, on my web site, under SP Page Builder Pro setttings, update license key gives 502 http errorduring saving the new license key.
Versions:
Joomla 4.4.14
SP Page Builder Pro 6.8
Staff replied
SP Page Builder
cannot setup new license key
1 reply
Paul Frankowski Senior Staff
1 month ago
· edited
Hi László,
there are 4 possible reasons:
- PHP settings, please increase your PHP limits: https://www.joomshaper.com/documentation/sp-page-builder/technical-requirements
- Or, a third-party plugin running on the onAfterStorage or onContentBeforeSave events throws a fatal PHP error when you hit Save.
- Or, Saving certain configuration strings or path settings triggers a security rule on server-level firewalls (like ModSecurity or Cloudflare). Can you disable ModSecurity for 3min in cPanel, recheck saving ?
- Or, maybe becuase SPPB Pro 6.8 was mostly developed for Joomla 5 and Joomla 6 engine.
Start from (1).
Log in to reply.