Site offline - Forum | JoomShaper
Staff replied Templates

Site offline

Asked by aleabasolucoes 5 years ago Last activity 5 years ago

Next, the website kairosslocadora.com.br is not opening the home, only the internal pages, you can see at http://www.kairosslocadora.com.br/sobre2, from this page you can access the others, but the problem it takes place at home and at the manager, who simply does not enter. Can someone help me?

14 replies

Paul Frankowski Senior Staff

Hi,
it looks a problem with HikaShop configuration database.

You should reinstall HikaShop component and check settings and save changes, it may help.
I hope you know that We are not HikaShop support.

aleabasolucoes Asked this

Okay, but actually, I don't use that component. I also can't install anything because the admin won't open either.

Paul Frankowski Senior Staff
  1. Maybe there is HikaShop module published there, which should be disabled.
  2. Why you cannot login to joomla administrator anymore?
aleabasolucoes Asked this

When accessing the administrator, I enter the login and password, and the page is all white. I do not know what to do.

Paul Frankowski Senior Staff
5 years ago · edited

But what have you done that it broken it?
Changed PHP version, installed or updated something.

Fixing it may be beyond free support if was caused by user (yours) actions, not directly our code.
Like when you would buy a car and lost keys to open doors and start engine. If you know what I mean.

To check what is wrong try this:

  1. Use FTP tool and edit configuration.php file, find line with public $error_reporting
    change value from "simple" or "default" to "maximum" , save settings.
  2. try to login again, and check what error message you would see.
aleabasolucoes Asked this
5 years ago · edited

I understand your observation perfectly, my friend. I've been working with Joomla for 10 years. It turns out that this particular site stopped working overnight. In contact with the server, Locaweb, they don't know what happened either.
Anyway, I did what you asked, and now you presented me with this error: Fatal error: Call to undefined method JApplicationAdministrator :: isClient () in / home / storage / d / fd / 4c / kairosslocadora / public_html / plugins / quickicon / phpversioncheck / phpversioncheck .php on line 208

I will try, again, to change the version of PHP.

--

When changing from PHP 5.6 to 7.0, now I can even see the administrator, with error: http://prntscr.com/xb2jx5

And now the site presents several errors as well: http://prntscr.com/xb2kv6

Paul Frankowski Senior Staff

It looks like something wrong with PHP version.
New Joomla needs PHP 7.1, 7.2 or 7.3.
With those all should work.
So you have to check & confirm what exatcly PHP version is used.

PHP 7.4 and PHP 8 is NOT recommended for Helix3 based templates.

temporary you can rename this folder
plugins/quickicon/phpversioncheck

aleabasolucoes Asked this

Following your advice, I am trying to install the HikaShop component, but I have this error when installing: http://prntscr.com/xb2ss9

aleabasolucoes Asked this

I'm trying to update everything, but now the site is showing an error: JHtmlJquery::token not found.

Paul Frankowski Senior Staff
5 years ago · edited
  1. But if you don't use this component, why you need this? Disable all HikaShop modules etc.
  2. Your installation error is from Joomla itself, it's beyond JoomShaper support. Sorry.
  3. Update Joomla first or reinstall core files, something may be damaged.
Log in to reply.