Technical Requirements | Spectrum - Documentation | JoomShaper


Updated Last: 04 October 2018

Technical Requirements

It is strongly recommended that you always use the latest stable version of Joomla to ensure all known bugs and security issues are fixed. Template will only function properly on Joomla 3.6 and newer versions.
To prevent problems with used components and installation freezes (never ending) use following settings:

  • PHP 5.6 or PHP 7.x
  • MySQLi 5.5+
  • PostgreSQL 9+

Note! Supports for PHP 5.3 and 5.4 ended long time ago.
Our SP PB component requires at least PHP 5.6 or later. We strongly recommend using 7.0.x.
To use QuickStart please use these php settings :

  • memory_limit --> at least 64M (128MB)
  • max_execution_time --> at least 240 (by default is set to 30 seconds only.)
  • Magic Quotes GPC off

These below settings of PHP are strongly recommended for Joomla! in order to ensure full compatibility and website security with latest version of Joomla!: 

In most cases those values can be changed in php.ini or .htaccess file. Please contact your web hosting service provider to be sure that your server complies with the requirements or to ask them where/how to change above PHP settings.

About recommended browser we suggest to use the latest version of Firefox, Safari, Chrome or Internet Explorer 10+. Please remember that Internet Explorer versions 8 and older are NOT supported anymore by Microsoft company.