Quickstart installation problems | Themis - Documentation | JoomShaper

Themis

Updated Last: 15 October 2020

Quickstart installation problems

Because JoomShaper Quickstart includes Joomla, demo content, additional extensions and their settings it requests correct PHP settings.

If during QuickStart installation you have a never-ending installation or it stuck/freezes on creating tables. You need to compare your PHP setting with Technical Requirements.

You can avoid this error, for example, by:

  • upgrade used PHP version (from PHP 5.x to 7.1+), and
  • increasing the maximum execution time for PHP to 400 or 600 (recommended).

 max_execution_time =  400 

You can make this change inside php.ini or inside .htaccess file. Make sure to restart your web server for the changes to take effect.
Go back to your System Information and check if your values have changed. If not, you should contact your hosting company for assistance in editing these values.

Note! If you don't know how to change PHP settings - please contact your hosting support. They should help you. Sometimes information on how to change PHP values is included on your hosting website Help/FAQ section.

If the above steps will not help - please make small customization:

QuickStart Installer customization

  1. Open in your text editor the following files:
    installation\sql\mysql\joomla.sql
    and
    installation\sql\mysql\sample_data.sql\
  2. Find all instances of ENGINE=InnoDB and change/replace to ENGINE=MyIsam
  3. Now return in your installation procedure one step back and try again.
  4. Use MySQL in choose field not MySQLi if you still have problems with database step.

------
* Once the install has completed go back and change it back to a value no more than 60.
** MyISAM is more supported and compatible with Joomla! in localhost environment.