Opt-in Form Mailchimp "timeout-or-duplicate" Error - Question | JoomShaper

Opt-in Form Mailchimp "timeout-or-duplicate" Error

BC

Bill Clements

SP Page Builder 2 weeks ago

I am using Joomla 4.1.4 and the latest version of SP Page Builder Pro. When I try and connect an opt-in form to our Mailchimp account I am getting the error "timeout-or-duplicate" error message. I have the correct API key and list id. Suggestions?

Thanks

0
13 Answers
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

Hi there,

Thanks for contacting us. Sorry for the inconvenience. Will you please provide me the Joomla administrator access to check the issue? I will check & get back to you soon. 

-Thanks

0
BC
Bill Clements
Accepted Answer
1 week ago

I have an Opt-In Form disabled currently in the Page Builder "Home" page in the NEWSLETTER section - the last Addon.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

Administrator access doesn't work.

0
BC
Bill Clements
Accepted Answer
1 week ago

Sorry - missed an 'o' in the username.

0
BC
Bill Clements
Accepted Answer
1 week ago

Missed an 'o' in the username.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

Username and password do not match or you do not have an account yet.

0
BC
Bill Clements
Accepted Answer
1 week ago

I just logged in with those credentials.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

I have checked using my API key & opt-in form & it works fine.

0
BC
Bill Clements
Accepted Answer
1 week ago

Okay .... so that doesn't help me. How can I figure out what is happening with my form???

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

I have checked your home page addon with my mailchimp credential and it works fine. I think your mailchimp credentials occurred the issue. Thanks

0
BC
Bill Clements
Accepted Answer
1 week ago

Mailchimp "credentials" - do you mean the API key and audience id? I have copied and pasted these into the fields.

Is there not some way to figure out what is going wrong? For you to tell me that it works for your account but it doesn't work for my account is absolutely no help to me!

0
BC
Bill Clements
Accepted Answer
1 week ago

So, I have figured out what the problem is with your opt-in form!

In Mailchimp, we had both the fields FIRST NAME and LAST NAME set as REQUIRED. When I removed the REQUIRED flag from LAST NAME which was not in the opt-in form your opt-in form worked correctly and submitted the data to Mailchimp.

The issue was having a Mailchimp field set to REQUIRED and not including that field in the opt-in form!

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 1 week ago

Glad to know that your problem solved. Will you please spend some to write a review about our product and support quality? 

https://extensions.joomla.org/extension/sp-page-builder/

0