Newsberg Didnt Work After Upgrade To Joomla 4.3.0 - Question | JoomShaper

Newsberg Didnt Work After Upgrade To Joomla 4.3.0

FS

Freiherr vom Stein

Template 1 year ago

Hello,

after an Upgrade to Joomla 4.3 Newsberg isnt working anymore. I must downgrade PHP to make Newsberg work with Joomla 4.3.0 - What can we do?

Regards

0
11 Answers
B
BRUNO
Accepted Answer
1 year ago #114246

Bonjour

I also use Newsberg and have not yet upgraded to Joomla 4.3.0.

Could the support specify if this update is possible for Newsberg with PHP 8 or not?

Thanks

0
IA
Ira Adams
Accepted Answer
1 year ago #114304

I have not been able to get it to work. I keep recieving the error below...

count(): Argument #1 ($value) must be of type Countable|array, null given

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 1 year ago #115000

Hello Freiherr vom Stein

Newsberg is not yet updated to PHP 8. It will be compatible soon. Please use PHP 7.4 until then.

Best regards

0
IA
Ira Adams
Accepted Answer
11 months ago #117791

Is there an estimated time frame for php 8 compatibility for newsberg?

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 11 months ago #117853

Hello Ira Adams

Sorry, we do not have any estimated date now. It will take some weeks.

Best regards

0
B
BRUNO
Accepted Answer
11 months ago #117841

Bonjour

I don't understand.

I use Newsberg with PHP 8.0.28 and Joomla 4.2.9.

https://prnt.sc/UBUB2xx_ODiQ

It seems that the problem is not PHP 8. The problem is PHP 8 with Newsberg and Joomla 4.3.x.

So here's my question again: is it possible to upgrade Joomla 4.2.9 to 4.3.x with Newsberg and PHP 8?

Thanks

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 11 months ago #117854

Hello BRUNO,

Thanks for your feedback. It could be. We will check the template with PHP 8.0 and with latest Joomla 4 and Joomla 3. Then we will make the template compatible and release an update.

Best regards.

0
IA
Ira Adams
Accepted Answer
11 months ago #120496

Any updates on the progess of this update? I have other components on my live site that require php8 but am held back waiting on an update to newsberg.

0
Ofi Khan
Ofi Khan
Accepted Answer
Support Agent 11 months ago #120517

Apology for the inconvenience. We do not have any ETA. It will be updated soon.

0
IA
Ira Adams
Accepted Answer
10 months ago #121014

Thanks for your hard work!

0
B
BRUNO
Accepted Answer
10 months ago #121429

Hello

Solution used for my site installed with Newsberg and running with PHP 8.0.28 and Joomla 4.2.9, since there is no Joomshaper solution:

Back to PHP 7.4

Install Joomla 4.3.2

Switch back to PHP 8

Will this work with your site? I have no idea!

Good luck to you.

0