ERROR With The Fixter Template: Update The Quickstart Joomla 4 Package! - Question | JoomShaper

ERROR With The Fixter Template: Update The Quickstart Joomla 4 Package!

Ximware

Ximware

Template 2 months ago

When installing the Joomla 4 Quickstart from the Fixter template I get the following error:

'An error has occurred. 0 Missing field in database: Joomla extension   extension_id.'

https://i.snipboard.io/JkmYy9.jpg

I saw other posts mentioning this error but the JoomShaper team has not prioritized this bug. At this time CMS Joomla is unusable.

0
6 Answers
Rashida Rahman
Rashida Rahman
Accepted Answer
Support Agent 2 months ago #155393

Hi there!

Sorry for your experience.

Would you please let us know which PHP version are you using there?

However, here is the technical requirements for Fixter template and quickstart installation process:

https://www.joomshaper.com/documentation/joomla-templates/fixter/technical-requirements

https://www.joomshaper.com/blog/how-to-install-quickstart-package-in-joomla-4

Best Regards

0
Ximware
Ximware
Accepted Answer
2 months ago #155498

Hello Rashida,

I was able to solve it, but I feel that JoomShaper should update their Quickstart packages and put both Joomla 4 and Joomla 5 versions, and obviously support PHP 8.1 onwards. My suggestion is to try to go with the minimum requirements supported and in some cases, recommended by Joomla.

This is what I did:

  1. I downgraded PHP 8.1 to PHP 7.4 at my hosting provider.
  2. I installed the quickstart package of the Fixter template for Joomla 4.
  3. I upgraded both Joomla and the extensions that come with the quickstart package offered by JoomShaper.
  4. When I managed to upgrade to Joomla 4.4.4, I was able to upgrade the PHP version back to 8.1.
  5. I upgraded to Joomla 5.

Now the site is working properly. No problems with any of the JoomShaper extensions, including the template.

I repeat... JoomShaper needs to put more love in the quickstart packages. Especially on older templates like Fixter.

0
Rashida Rahman
Rashida Rahman
Accepted Answer
Support Agent 2 months ago #155760

Hi Ximware,

Thanks for the explanation and suggestions.

I will share the thoughts.

0
A
Artur
Accepted Answer
2 months ago #155499

Joomshaper doesn't care about this at all. I have reported this several times. It's been a while since I submitted my submissions. That's why I stopped using ready-made products. Later only problems.

0
R
Revilo
Accepted Answer
1 month ago #159548

This is very frustrating! I just wanted to install the latest template LuxeVista with Quickstart Pack Joomla 4 on my server! But it doesn't work! My server is up to date and runs on PHP 8! I can't install the sample files! This means that all Joomshaper templates with sample files are useless! I'm definitely not going to install an old PHP version just because of Joomshaper so that I can install a Joomshaper template! Please fix this error!? Your software should always be up to date!

Frustrating

0
Ximware
Ximware
Accepted Answer
1 month ago #159550

Can you downgrade to PHP version 7.4?

I was able to do it by installing Joomla 4 on that version of PHP. Then I upgraded Joomla 4 to the latest version and from there I was able to switch to PHP version 8.1 (in my case).

But it is very frustrating that JoomShaper does not offer Quickstart packages with Joomla 5.

0