Unable to upload to SP Page Builder Media Manager - Forum | JoomShaper
Solved SP Page Builder

Unable to upload to SP Page Builder Media Manager

Asked by David Woolterton 10 months ago Last activity 10 months ago

I have been using Joomla and SP Page Builder Pro for around 10 years now, but I have been out of the game for 2 - 3 years. I have just got back to doing some website stuff for my own personal use. I have just created an empty Joomla site with Version 6.0.0, Helix Ultimate 2.2.1, JCE Pro editor 2.9.96 and SP Page Builder 6.1.2.

The Apache webserver is running php 8.4.

Now I have 2 issues which may or maynot be related. The first of which is I am unable to upload to Media Manager.

I keep getting Request status failed with code 500. I belive this to be a SP Page Builder issue as I am able to upload via the Joomla way.

The second issue is I am unabel to access the SP Page Builder Options page from within the Global configuration.

Any assistance would be most greatfully appriciated.

David Woolterton

www.helicopter.me.uk

Accepted answer

Marked as the solution
Atick Eashrak Shuvo Staff

Thank you for confirming — I’m glad everything is working now.

No need to worry; the issue was on our end. We’ve already applied the fix, and it will also be included in the upcoming update to ensure it doesn’t happen again.

If you need anything else, feel free to let us know.

Please marked the issue as solved

8 more replies

Atick Eashrak Shuvo Staff

Hello David Woolterton,

Sorry for the inconvenience you're experiencing. Could you please recheck the credentials you've provided?

Looking forward to your response.

Best regards

David Woolterton Asked this

They should work now as I have reset the password to what was provided.

Thank you

Atick Eashrak Shuvo Staff

Hello David,

Sorry for the inconvenience you're experiencing. The issue with uploading to the SP Page Builder Media Manager is likely due to the GD PHP extension being missing. This extension is necessary for image processing functions.

Could you please contact your hosting provider and request that they enable the GD extension for your PHP setup? This should resolve the problem.

If this doesn't solve the issue, please reach out and I'll look into it more deeply.

Best regards

David Woolterton Asked this

Thank you this has indeed fixed the media upload issue.

However there is still the issue of not being able access the SP Page Builder options from the Global Confituration page.

Kind Regards David

Atick Eashrak Shuvo Staff

Hello David,

Sorry for the inconvenience you're experiencing. To investigate this further, could I please create a full backup of your site to check the issue on my local machine?

Also, please note that all settings, except for permission settings, can be found within the SP Page Builder settings.

Best regards

David Woolterton Asked this

Thank you, and yes please do take a full backup of my site for your own local testing. This will not affect what I am currently doing.

Atick Eashrak Shuvo Staff

I apologize for the inconvenience caused. Could you please check now and let me know if the issue is resolved on your end?

Looking forward to your response.

Best regards

David Woolterton Asked this

Again thank you very much, and yes I can confirm all is working now. Was the issue anything I could have sorted or was it something you need to deal with.

Log in to reply.