404 Error After Upgrading Sp Page Builder Pro - Question | JoomShaper

404 Error After Upgrading Sp Page Builder Pro

P

Pierre

SP Page Builder 8 months ago

This morning I upgraded SP PAGE BUILDER Pro on my website (Kidzy template) after that I got this error:

.border-radius is undefined: /home/.../www/templates/shaper_kidzy/less/master.less on line 14

I can acess the administrator part of my website... but no pages...

Could you please help me to resolve this ? I have to show this website to my client in two days... so it's really annoying. Thanks for your help

1
25 Answers
Marc Dechèvre
Marc Dechèvre
Accepted Answer
8 months ago

OK txs Toufiq.

So in plain words for those following this thread, it gives this :

  • edit /less/theme.less of your template
  • identify every line starting with .border. Exemple: .border-radius(0);
  • change it to plain CSS syntax. Exemple: border-radius: 0;

There were two rows to adapt in the case of Shaper_Macro. Now that the two rows are corrected, the 404 error message is solved.

Txs again.

Marc

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 8 months ago

Hi there,

Thanks for contacting us. Sorry for the inconvenience. Will you please follow the instruction to find out the solution.

  1. Enable the Error Reporting https://prnt.sc/wbqvjk
  2. Disable the SEF https://prnt.sc/wbqvuw
  3. Disable the JCE editor https://prnt.sc/wbqwai
  4. Then try to check the front end editing.

Note: Before apply this process, Please keep a backup of your site. If you cannot find out the solution. Please make an akeeba backup & share with me the zip file. I will check from my end & let you know the solution after investigation my end.

https://drive.google.com/file/d/1HwEmKAzw-uVWQHdASGHU31nJaJKBSR56/view

-Thanks

0
P
Pierre
Accepted Answer
8 months ago

Thanks for your fast help...

I make all changes you asked but it didn't changed anything so I maked a backup as asked. Is there a private way to share the URL of the zip file with you ?

Thanks (a looooot)

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 8 months ago

Please read the blog post how to share hidden content in your forum post. https://www.joomshaper.com/blog/introducing-more-optimized-and-private-support-forum

0
P
Pierre
Accepted Answer
8 months ago

Thanks... I edited my initial question with my Zip Url into the hidden section...

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 8 months ago

Please update the Template. Your problem will be solved. Thanks

0
P
Pierre
Accepted Answer
8 months ago

Hi... could you please explain me how to do this ? Have I to download the "new" version (the actual 2.2 is the same that I installed, so it's not really an upgrade) and install it or is there a specific way to do it ?

Thanks a lot.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 8 months ago
0
GS
Gurdip Singh
Accepted Answer
8 months ago

I am experiencing the same error, what's the solution?

EDIT: I upgraded my template, and that fixed the issue. Thanks.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 8 months ago

Glad to heard that your problem solved. Please close this thread by accepting the most helpful answer so that someone else can find the solution.

0
P
Pierre
Accepted Answer
8 months ago

PS: Could you please suppress the link to my website upgrade in your previous answer ? There are some personal data... Thanks.

0
P
Pierre
Accepted Answer
8 months ago

OMG..... I got the same error again... but in know how to reproduce it... it happens when I paste the link of the facebook in the template parameters... I try to set it back to "#" as before but the error last.

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 8 months ago

Please clear your Joomla cache and check again.

PS: Could you please suppress the link to my website upgrade in your previous answer ? There are some personal data... Thanks.

Share link

0
P
Pierre
Accepted Answer
8 months ago

Hi... It didn't solve the problem. After changing the facebook link in the template parameters I have again a 404 error.

0
P
Pierre
Accepted Answer
8 months ago

Hi... are you still there ???

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 8 months ago

Yes, I am here. Can you give me the administrator access?

0
P
Pierre
Accepted Answer
8 months ago

Hi... for the moment I can work on my website by disabling Less compilation. But... it isn't really a solution.

The info to get into the admin part are into the hiden field.

Thanks

1
Toufiq
Toufiq
Accepted Answer
Senior Staff 8 months ago

No problem found in your website. Even i have checked front end editing from the page builder and it works fine.

https://prnt.sc/we3wmx

0
Marc Dechèvre
Marc Dechèvre
Accepted Answer
8 months ago

Same issue here with Shaper_Macro template (when "compile Less to CSS" is enabled). The website also has SP Page Builder.

So I guess there is an error in some error in the Less files. Could you pls say exactly what line should be corrected ? Txs !

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 8 months ago
0
Toufiq
Toufiq
Accepted Answer
Senior Staff 8 months ago

You are most welcome & Thanks

0
T
tony
Accepted Answer
8 months ago

I had to diable less as well, quickest solution Compile LESS to CSS Set to No, in advanced, Template settings

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 8 months ago

@tony you can follow the video instructions or your own process. Thanks

0
C
ccws
Accepted Answer
8 months ago

Thanks it helped me with aspasia please fix for next update

0
Toufiq
Toufiq
Accepted Answer
Senior Staff 8 months ago

@ccws we will fix it next update. Thanks

0